Poste-italiane has some technical problem with slow tracking updates.
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Apr 24, 2023 - 23:42 EDT
Update
It is partially fixed and team is still working to get it fixed completely.

We'll keep you informed for further updates.
Posted Apr 19, 2023 - 23:28 EDT
Investigating
The poste-italiane has some problem with the courier side as the success rate of getting tracking updates is very low. Our team is working on this and will keep you updated.
Posted Apr 19, 2023 - 07:38 EDT
This incident affected: Couriers Tracking System.