TNT - Delayed Tracking Updates
Incident Report for AfterShip Tracking
Resolved
The issue has been resolved and all services are back to normal for TNT
Posted Jun 03, 2021 - 01:41 EDT
Identified
This issue has been identified and engineers are working on the fix
Posted Jun 02, 2021 - 23:40 EDT
Investigating
Due to an ongoing issue, there might be some delay in getting delivery updates. We will keep an eye out and update here once resolved.
Slug: tnt
Posted Jun 02, 2021 - 08:51 EDT
This incident affected: Couriers Tracking System.