Tracking Delay for Courier China Post
Incident Report for AfterShip Tracking
Resolved
The issue has been resolved and we are getting the updates for 'china-post' & 'china-ems'
Posted May 23, 2022 - 07:57 EDT
Investigating
There is some tracking delay to update for china post. Our Team is working on this.

Affected slugs: 'china-post' & 'china-ems'
Posted May 23, 2022 - 02:13 EDT
This incident affected: Couriers Tracking System.