USPS tracking updates delay
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Dec 01, 2020 - 01:49 EST
Investigating
USPS is facing a technical issue resulting in delayed tracking updates.
Posted Dec 01, 2020 - 01:36 EST
This incident affected: Couriers Tracking System.