The success rate of slug dpd and dpd-de has decreased due to technical issue
Incident Report for AfterShip Tracking
Resolved
The performance of slug dpd and dpd-de tracking updates are recovered now and we are getting the updates.
Posted Jul 27, 2023 - 06:12 EDT
Investigating
The success rate of slug dpd and dpd-de has decreased from 2023.07.26 17:06 UTC+8 which is causing slow tracking updates, we will monitor and try to find a way to fix it.
Posted Jul 26, 2023 - 23:09 EDT
This incident affected: Couriers Tracking System.