India Post Tracking Unavailable

Incident Report for AfterShip

Resolved

The incident has now been resolved, and the service is fully operational.
Posted Aug 05, 2025 - 00:55 EDT

Investigating

We’re currently experiencing a disruption with India Post tracking updates due to a third-party issue. Our team is investigating further.
Posted Aug 04, 2025 - 02:34 EDT
This incident affected: Couriers Tracking System.