[mondialrelay] is currently unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the service is fully operational.
Posted Dec 09, 2024 - 04:41 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "mondialrelay" since 2024-12-06 12:00:00 UTC.

We are working on it and keep you updated on the progress.
Posted Dec 08, 2024 - 22:36 EST
This incident affected: Couriers Tracking System.