AfterShip Courier UPS, UPS Mail Innovation and UPS Reference are down
Incident Report for AfterShip
Resolved
The issue has been resolved now. All services are back to normal.
Posted Jul 15, 2021 - 07:50 EDT
Update
The deployment is in progress and the issue will be fixed very soon.
Posted Jul 15, 2021 - 06:00 EDT
Identified
The team has identified the issue and the fix will be deployed soon.
Posted Jul 15, 2021 - 00:40 EDT
Investigating
AfterShip Courier UPS, UPS Mail Innovation, and UPS Reference are down since 2 AM HKT. The tracking updates are not available for the time being for the mentioned couriers. The team is currently investigating the issues.
Posted Jul 14, 2021 - 20:58 EDT
This incident affected: Couriers Tracking System.