[swiship] is currently partially unavailable
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 04:18 EST
Update
The incident has been resolved and the services are fully operational.
Posted Nov 17, 2024 - 04:15 EST
Investigating
We have been facing issues while getting the tracking updates for the carrier "swiship" since 2024-11-13 12:00:00 HKT.

Our team is working on priority to fix it. We'll update you on the progress.
Posted Nov 14, 2024 - 22:29 EST
This incident affected: Couriers Tracking System.