[spanish-seur-api] is currently unstable

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted May 13, 2025 - 08:40 EDT

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 08:40 EDT

Investigating

We are currently experiencing an issue while getting the tracking updates for the carrier "spanish-seur-api". Our team is in touch with the carrier to get this fixed.

We will provide updates as soon as more information becomes available. Thank you for your patience.
Posted May 13, 2025 - 07:05 EDT
This incident affected: Couriers Tracking System.