[mrw] is currently partially unavailable
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 03:05 EDT
Update
The incident has been resolved and the service is fully operational.
Posted Oct 15, 2024 - 03:01 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "mrw" since 2024-10-14 20:00 HKT.

Our team is working on it. We'll update you on the progress.
Posted Oct 14, 2024 - 22:24 EDT
This incident affected: Couriers Tracking System.